java's System.out.printf function can be used to print formatted output. The purpose of this exercise is to test your understanding of formatting output using printf.

 

To get you started, a portion of the solusion is provided for you in the editor; you must format and print the input to complete the solution.

 

Input Format

 

Every line of input will contain a String followed by an integer.

Each String will have a maximum of 10 alphabetic characters, and each integer will be in the inclusive range from 0 to 999.

 

Output Format

 

In each line of output there should be two columns:

The first column contains the String and is left justfied using exactly 15 characters.

The second column the integer, expressed in exactly 3 digits; if the original input has less than three digits, you must pad your output's leading digits with zeroes.

 

Sample Input

java 100
cpp 65
python 50

 

Sample Output

================================
java 100
cpp 65
python 50
================================

 

Explanation

 

Each String is left-justified with trailing whitespace through the first 15 characters. The leading digit of the integer is the 16th character, and each integer that was less than 3 digits now has leading zeroes.

 

더보기

formatted : 구성 방식

purpose : 목적

exercise : 연습

portion : 부분

provided : 제공

followed : 뒤를 잇다

inclusive : 포괄적

range : 범위

each : 각각의

justified : 당연한, 이유가있는

expressed : 표현된

digits : 숫자의

less : 더 적은

 

import java.util.Scanner;

public class Solution {

    public static void main(String[] args) {
            Scanner sc=new Scanner(System.in);
            System.out.println("================================");
            for(int i=0;i<3;i++)
            {
                String s1=sc.next();
                int x=sc.nextInt();
                if(x >= 100) {
                    System.out.printf("%-15s%d\n",s1, x);    
                } else if(x >= 10) {
                    System.out.printf("%-15s0%d\n",s1, x);
                } else {
                    System.out.printf("%-15s00%d\n",s1, x);
                }
            }
            System.out.println("================================");
    }
}

  • String와 Int 사이의 공백을 15칸으로 맞춰줘야한다. (printf, %-15s사용)

'알고리즘 > Hackerrank' 카테고리의 다른 글

[Hackerrank] Operators  (0) 2021.09.25
[Hackerrank] Data Types  (0) 2021.09.25
[Hackerrank] Picking Numbers  (0) 2021.09.25
[Hackerrank] Forming a Magic Square  (0) 2021.09.23
[Hackerrank] Java Loops 1  (0) 2021.09.23